CiscoTik

Networking Administration

CiscoTik

Networking Administration

CiscoTik

آموزش شبکه های مبتنی بر سیسکو و میکروتیک و ...

طبقه بندی موضوعی
محبوب ترین مطالب
نویسندگان
  • ۱
  • ۰

Setup VPN PPTP server on Mikrotik

Setup VPN PPTP server on Mikrotik

سناریو
VP clients(192.168.90.2-10) — eth1 (public ip) --- eth2 (LAN 192.168.99.1) — LAN Clients (192.168.99.x/24)

سیستم مورد نیاز
  Mikrotik 

در ابتدا یک pool ایجاد کرده و مقادیر آدرس زیر را به آن میدهیم .(یک رنج IP) 
در این مثال یک pool برای کلاینت های Vp قرار می دهیم.


Example create pool for 9 VPN clients with ip address 192.168.90.2-192.168.90.10
/ip pool
add name=vpn-pool ranges=192.168.90.2-192.168.90.10


ساختن یک profile برای VP 

/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8,4.2.2.4 local-address=\
    192.168.90.1 name=vpn-profile only-one=default remote-address=vpn-pool \
    use-compression=default use-encryption=yes use-mpls=default \
    use-vj-compression=default

نکته: شکل فوق در قسمت DNS غلط می باشد که باید مطابق دستور بالایی آدرس های 8.8.8.8 و 4.2.2.4 ست شوند 

ساختن اینترفیس PPTP server

/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=vpn-profile enabled=yes \
    keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled

/interface pptp-server
add disabled=no name=pptp-vpn-server user=""

 
ساختن یوزر برای کلاینت های VP
/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=bachem \ password=adadeh profile=vpn-profile routes="" service=pptp add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=tempe \ password=adadeh profile=vpn-profile routes="" service=pptp add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=tahu \ password=adadeh profile=vpn-profile routes="" service=pptp

ایجاد NAT 

 chain=srcnat action=masquerade out-interface=ether1 log=no log-prefix=""


ساخت کانکشن و ارتباط تست بین سرور و کلاینت

و در آخر  log میکروتیک
 

نظرات (۳)

سلام مهندس 
وبلاگت خیلی خوب شده ، بعد از مدت ها گذرم افتاد   حال کردم ، موفق باشی عزیز 
پاسخ:
سلام 
ممنون مهندس جان . لطف داری 
  • علیرضا باقری
  • سلام سایت مفیدی دارین خیلی خوبه..
    در مورد voip آموزشی میتونید بزارید البته فارسی...ممنون
    پاسخ:
    سلام دوست عزیز
    ممنون از حسن نظرتون
    تا بحال پروژه ای در مورد voip  انجام ندادم و اطلاعاتی در این زمینه ندارم . ولی به محض پیدا کردن یک سورس یا ... مفید حتما براتون mail میکنم.

    سلام ، خسته نباشید
    من اگه بخوام یوزرهام  با وی پی ان وصل شن به اینتزنت همین روال رو باید انجام بدهم
    رنج ای پی کلانیت های سرور 172.20.1.x هست ، حالا  IP وی پی ان رو باید چند بگذارم ؟ حدود 100 تا کاربر دارد.

    ارسال نظر

    ارسال نظر آزاد است، اما اگر قبلا در بیان ثبت نام کرده اید می توانید ابتدا وارد شوید.
    شما میتوانید از این تگهای html استفاده کنید:
    <b> یا <strong>، <em> یا <i>، <u>، <strike> یا <s>، <sup>، <sub>، <blockquote>، <code>، <pre>، <hr>، <br>، <p>، <a href="" title="">، <span style="">، <div align="">
    تجدید کد امنیتی