CiscoTik

Networking Administration

CiscoTik

Networking Administration

CiscoTik

آموزش شبکه های مبتنی بر سیسکو و میکروتیک و ...

طبقه بندی موضوعی
محبوب ترین مطالب
نویسندگان
  • ۱
  • ۰

با سلام خدمت بینندگان ویلاگ من
پیرو پست قبلی و در این پست قرار هست که یک سناریو در مورد Q in Q تونل برای شما قرار بدهم.

در این پست پیکر بندی و نحوه کار 802.1Q tunnel راکاملا توضیح می دهم.همبندی یا توپولوژی به صورت شکل زیر است:

Cisco Q-in-Q Lab Topology


در دو طرف این شبکه دو روتر قرار دارد که سمت مشترکین می باشد.شبکه  service provider نیز شامل سوییچ ها می باشد.
مشترکین قضد ارتباط از طریق vlan 110  را با هم دارند و در واقع این ارتباط باید از طریق service provider باید برقرار و انجام شود.


در این سناریو service provider از vlan 313 برای انتقال کل ترافیک بین دو مشترک استفاده می کند




و اما بحث شیرین پیکر بندی !

R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#interface fastEthernet 0/0.110
R1(config-subif)#encapsulation dot1Q 110
R1(config-subif)#ip address 192.168.110.1 255.255.255.0
R2(config)#interface fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#interface fastEthernet 0/0.12
R2(config-subif)#encapsulation dot1Q 12
R2(config-subif)#ip address 192.168.110.2 255.255.255.0


در سوییچ های ISP نیز تنظیمات به قرار زیر است:



SW1(config)#interface fastEthernet 0/19
SW1(config-if)#switchport trunk encapsulation dot1q 
SW1(config-if)#switchport mode trunk
SW2(config)#interface fastEthernet 0/21
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk 
SW3(config)#interface fastEthernet 0/19 
SW3(config-if)#switchport trunk encapsulation dot1q 
SW3(config-if)#switchport mode trunk

SW3(config)#interface fastEthernet 0/21
SW3(config-if)#switchport trunk encapsulation dot1q 
SW3(config-if)#switchport mode trunk

و حالا داریم:


SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport access vlan 123
SW1(config-if)#switchport mode dot1q-tunnel
SW2(config)#interface fastEthernet 0/2
SW2(config-if)#switchport access vlan 123
SW2(config-if)#switchport mode dot1q-tunnel
SW3(config)#vlan 313

در این مرحله ارتباط دو سمت (مشترکین) تست می شود :


R1#ping 192.168.110.2           

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.110.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

تست ارتباط کاملا موفقیت آمیز بود و دو طرف قادر به دیدن و انتقال اطلاعات در و از طریق (!) Vlan 313 شده اند. خدار و شکر !

اما برای اطمینان هم که شده  می خواهم چند دستور برای بررسی کار خودمون با feedback مربوطه در این جا بگذارم:


SW1#show dot1q-tunnel 

dot1q-tunnel mode LAN Port(s)
-----------------------------
Fa0/1
SW2#show dot1q-tunnel 

dot1q-tunnel mode LAN Port(s)
-----------------------------
Fa0/2


و یک دستور کاربردی دیگه :


SW1#show interfaces fa0/19 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/19      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/19      1-4094

Port        Vlans allowed and active in management domain
Fa0/19      1,313

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/19      1,313
SW2#show interfaces trunk 

Port        Mode             Encapsulation  Status        Native vlan
Fa0/21      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/21      1-4094

Port        Vlans allowed and active in management domain
Fa0/21      1,313

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/21      1,313
SW3#show interfaces trunk 

Port        Mode             Encapsulation  Status        Native vlan
Fa1/0/19    on               802.1q         trunking      1
Fa1/0/21    auto             n-802.1q       trunking      1

Port        Vlans allowed on trunk
Fa1/0/19    1-4094
Fa1/0/21    1-4094

Port        Vlans allowed and active in management domain
Fa1/0/19    1,313
Fa1/0/21    1,313

Port        Vlans in spanning tree forwarding state and not pruned
Fa1/0/19    1,313
Fa1/0/21    1,313


در اینجا (در قسمت سرویس دهنده) vlan 110 را مشاهده نمی کند در نتیجه هیچ ترافیکی از این vlan در سرویس دهنده دیده نخواهد شد . دلیل آن هم اینست که این vlan در vlan 313 بصورت encapsulدر آمده است.

راه دیگر بررسی ادعای فوق بررسی spanning-tree می باشد که در زیر آورده شده است:

SW1#show spanning-tree vlan 110

Spanning tree instance(s) for vlan 110 does not exist.
SW2#show spanning-tree vlan 110 

Spanning tree instance(s) for vlan 110 does not exist.
SW3#show spanning-tree vlan 110 

Spanning tree instance(s) for vlan 110 does not exist.

سوییچ های ISP هیچ همبندی spanning-tree برای vlan 110 ندارند   زیرا برایش مهم نیست که مشترکین در دو سمت از کدام Vlan استفاده می کنند.ISP ها فقط به Vlan  خودشان یعنی vlan 313 استفاده می کنند.

802.1Q tunneling has some more tricks up its sleeve, one of the things it can do is tunnel some layer 2 protocols. Take a look below

SW1(config)interface fastEthernet 0/1
SW1(config-if)#l2protocol-tunnel ?
  cdp                 Cisco Discovery Protocol
  drop-threshold      Set drop threshold for protocol packets
  point-to-point      point-to-point L2 Protocol
  shutdown-threshold  Set shutdown threshold for protocol packets
  stp                 Spanning Tree Protocol
  vtp                 Vlan Trunking Protocol
  <cr>
If you want it can tunnel CDP, VTP, STP and even point-to-point protocols like PAgP or LACP (Etherchannel). Let me show you what happens when you tunnel CDP traffic:

...........


نظرات (۴)

سلام..وبلاگت خیلی خوبه....
منم شمارو دعوت میکنم از وبلاگ من دیدن کنید...نظر یادتون نره...
امضا:
ت و ی ل د
با سلام
من یک پروژه با qinq انجام دادم سرعت برنامه های وب به شدت کم شد چرااااا؟

تا قبل از این خلیلی بهتربود

من نیاز به یک سناریو پیاده سازی یک شبکه در gns3 هستم

پاسخ:
سلام . در قسمت پیوند های وبلاگ سایت هایی هستند که داخلشون سناریو هایی از مبتدی تا پیشرفته قرار داره. در همین وبلاگ هم (در مطالب قدیمی ) سناریو هایی در حد CCNP Route قرار داده شده. 
http://networklessons.com/ccnp-route-lessons/
http://freeccnplab.com/
http://packetlife.net/blog/category/routing/
فقط توجه داشته باشید که GNS3 (البته نسخه ای که من استفاده می کنم) سوییچ رو نداره .
با سلام
من روی یک لینک vpls مخابرات از qinq استفاده کردم
سرعت برنامه ها به شدت کم شد
ولی وقتی از vpn در بستر qinq استفاده میکنم سرعت خوب میشه.
فکر کنم به mtu مربوط میشه چون طبق برخی داکیومنت ها mtu  سوییچ ها باید 1504بشه ولی مخابرات نمیخواد (نمیتونه) اینکار را انجام بده
کسی نظری نداره؟

ارسال نظر

ارسال نظر آزاد است، اما اگر قبلا در بیان ثبت نام کرده اید می توانید ابتدا وارد شوید.
شما میتوانید از این تگهای html استفاده کنید:
<b> یا <strong>، <em> یا <i>، <u>، <strike> یا <s>، <sup>، <sub>، <blockquote>، <code>، <pre>، <hr>، <br>، <p>، <a href="" title="">، <span style="">، <div align="">
تجدید کد امنیتی